Audio en Debian Squeeze

3 08 2010

He estado un tiempo peleando con el audio en Debian Squeeze. El sonido a veces se ponía solo como por arte de magia y otras veces era imposible.

He buscado por Internet como solucionar el problema pero en casi todos los sitios dan respuestas distintas. Y a mi, no me funcionaban todas, así que al final mezclando un poco de un sitio y un poco de otra he conseguido que funcione.

Aquí pongo los pasos que seguí para lograr que funcione.

Primero tenemos que hacer un:

lsmod | grep snd

y después miramos cual es la tarjeta que tenemos que usar entre los resultados y apuntamos su numero.

Escribimos en una terminal:

alsamixer -c y numero de tarjeta

Después listamos los módulos de sonido y vemos cual es el que queremos usar.

cat /proc/asound/modules

Luego editamos el archivo  /etc/modprobe.d/alsa-base.conf y quitamos el -2 y ponemos un 0 en el modulo principal.

Después de estos pasos reiniciamos el sonido con un simple

alsa force-reload

y se supone que ya tiene que funcionar.

PD: Puede que el dispositivo esté silenciado, para solucionarlo subís el volumen con “Kmix” si estáis en KDE o si no también lo podéis hacer desde la terminal escribiendo
$ alsamixer

Espero que les sirva :)


Acciones

Information

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: